Back to overview
Degraded

profitbase.biz degraded

Mar 04 at 03:29pm CET
Affected services
profitbase.biz

Resolved
Mar 04 at 03:40pm CET

profitbase.biz recovered.

Created
Mar 04 at 03:29pm CET

profitbase.biz main page went down. This is only a static page showing that there's nothing to see here.